aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..776e878
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "finbudg"
+version = "0.1.0"
+edition = "2018"
+description = "Quick cli tool to calculate your expenses and balance for a set period of time."
+license = "MIT"
+readme = "README.md"
+authors = ["Yaroslav de la Peña Smirnov <contact@yaroslavps.com>"]
+homepage = "https://www.yaroslavps.com/"
+repository = "https://github.com/Yaroslav-95/finbudg"
+
+[dependencies]
+clap = "2.33"
+colored = "2.0"
+chrono = "0.4"
+budget = { path = "budget" }
+
+[workspace]
+members = [
+ "budget"
+]
+
+[profile.release]
+lto = true