aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorYaroslsav-95 <contact@yaroslavps.com>2018-01-31 08:27:11 +0300
committerYaroslsav-95 <contact@yaroslavps.com>2018-01-31 08:27:11 +0300
commit28b67ad39af15d27bad7e55a0ae7fafe91139239 (patch)
treeb94b7d55bfc8b95f2a3c0b96fe17d6eeee85589f /setup.py
parent40949b252c9929c755715d3e32df47cd82b095a0 (diff)
downloadw3blog-28b67ad39af15d27bad7e55a0ae7fafe91139239.tar.gz
w3blog-28b67ad39af15d27bad7e55a0ae7fafe91139239.zip
Initial
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py36
1 files changed, 36 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..88265df
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,36 @@
+import os
+from setuptools import find_packages, setup
+
+with open(os.path.join(os.path.dirname(__file__), 'README.md')) as readme:
+ README = readme.read()
+
+# allow setup.py to be run from any path
+os.chdir(os.path.normpath(os.path.join(os.path.abspath(__file__), os.pardir)))
+
+setup(
+ name='django-weblog',
+ version='0.2.1',
+ packages=find_packages(),
+ include_package_data=True,
+ license='BSD License',
+ description='A simple blog engine for Django with multilingual capabilities.',
+ long_description=README,
+ url='https://www.yaroslavps.com/',
+ author='Yaroslav de la Peña Smirnov',
+ author_email='contact@yaroslavps.com',
+ classifiers=[
+ 'Environment :: Web Environment',
+ 'Framework :: Django',
+ 'Framework :: Django :: 1.11',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: BSD License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Topic :: Internet :: WWW/HTTP',
+ 'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
+ ],
+) \ No newline at end of file